web development

Wie man Inhalte nach dem Neustart von Strapi bearbeitet

Wenn ich strapi neu strapi , kann ich keine Inhalte mehr bearbeiten und erhalte diese Warnung:

The autoreload feature is required to use this plugin. 
Start your server with strapi develop

Um das richtige Problem zu lösen, bräuchte ich mehr Details, aber ich bin auf das gleiche Problem gestoßen, als ich verwendet habe yarn start . Stattdessen habe ich das yarn strapi dev verwendet , das strapi mit der richtigen Konfiguration ausgeführt hat.

Ich kann den Server betreiben und Inhalte bearbeiten; Ich habe jedoch zunächst versucht, die Produktions- und Staging -Dateien server.json so zu ändern, dass sie Folgendes enthalten, aber das hat nicht funktioniert.

"autoReload": {
  "enabled": true
},



Ich hatte das gleiche Problem. Ich habe es behoben, indem ich npx strapi dev ausgeführt habe .

Im Entwicklungsprozess Ihres Projekts müssen Sie zum Anpassen (Hinzufügen/Entfernen/Ändern) des Inhalts Ihrer API den Server in einem Entwicklungsmodus starten, was über npx strapi dev erfolgt. Es gibt ein ganzes Befehlszeilenhandbuch hier .