Elastic Kubernetes Service

Impossible de mettre à niveau l'EKS

Hi,

J'ai un cluster EKS avec la version 1.16 et j'essaie de mettre à jour vers la version 1.17 mais j'ai échoué avec l'erreur suivante en raison de l'absence de groupe de sécurité par défaut (supprimé)

2021-11-13 09:19:19 mettra à niveau le plan de contrôle du cluster "xxx" de la version actuelle "1.16" vers "1.17" Erreur : InvalidRequestException : le groupe de sécurité "sg-0fdxxx" n'existe pas (Service : AmazonEC2 ; État Code : 400 ; Code d'erreur : InvalidGroup.NotFound ; ID de demande : xxx-xxx-xxx-xxx-xxx ; Proxy : null)

Il semble qu'il n'y ait pas d'autre moyen de le mettre à jour,alors j'attends la mise à jour forcée d'AWS lorsque la date de fin d'assistance arrive.Cependant,rien ne s'est produit.Je voudrais donc savoir s'il est possible de restaurer l'ancien groupe de sécurité ou de supprimer le groupe par défaut dans le cluster actuel pour permettre la mise à jour ou non.

Thanks

S'il s'agissait du groupe de sécurité du plan de contrôle, je ne pense pas que vous puissiez le modifier et vous ne pourrez pas recréer l'ID du groupe de sécurité. Votre meilleure option à ce stade consiste à reconstruire le cluster. Veuillez également consulter : https://github.com/aws/containers-roadmap/issues/738




Oui,j'ai vu ce problème il y a longtemps.Cependant,mon cluster ici est un cluster de production et il faudra plus d'efforts pour reconstruire et migrer tout ce qui s'y trouve.Je me demande également pourquoi la mise à jour forcée ne se produit pas.Au moins,je peux essayer de planifier un temps d'arrêt pour cela.