apt

Je ne peux rien installer avec apt:Le dépôt 'http://gb.archive.ubuntu.com/ubuntu hirsute Release' n'a plus de fichier Release.

Je suis sur Ubuntu 21.04 et j'essaie d'installer des paquets.Je n'ai eu aucun problème jusqu'à aujourd'hui,et maintenant j'ai ces erreurs qui apparaissent :

$ sudo apt update && sudo apt upgrade -y
Ign:1 http://gb.archive.ubuntu.com/ubuntu hirsute InRelease
Ign:2 http://gb.archive.ubuntu.com/ubuntu hirsute-updates InRelease
Ign:3 http://gb.archive.ubuntu.com/ubuntu hirsute-backports InRelease
Ign:4 http://gb.archive.ubuntu.com/ubuntu hirsute-security InRelease
Err:5 http://gb.archive.ubuntu.com/ubuntu hirsute Release
  404  Not Found [IP: 185.125.190.36 80]
Err:6 http://gb.archive.ubuntu.com/ubuntu hirsute-updates
  404  Not Found [IP: 185.125.190.36 80]
Err:7 http://gb.archive.ubuntu.com/ubuntu hirsute-backports Release
  404  Not Found [IP: 185.125.190.36 80]
Err:8 http://gb.archive.ubuntu.com/ubuntu hirsute-security
  404  Not Found [IP: 185.125.190.36 80]
Reading package lists... Done
E: The repository 'http://gb.archive.ubuntu.com/ubuntu hirsute Release' n'a plus de fichier Release.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://gb.archive.ubuntu.com/ubuntu hirsute-updates Release' n'a plus de fichier Release.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://gb.archive.ubuntu.com/ubuntu hirsute-backports Release' n'a plus de fichier Release.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://gb.archive.ubuntu.com/ubuntu hirsute-security Release' n'a plus de fichier Release.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Et pour le paquet que j'essaie d'installer :

$ sudo apt install gcc-10-plugin-dev
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  libgmp-dev libgmpxx4ldbl libmpc-dev libmpfr-dev
Suggested packages:
  gmp-doc libgmp10-doc libmpfr-doc
The following NEW packages will be installed:
  gcc-10-plugin-dev libgmp-dev libgmpxx4ldbl libmpc-dev libmpfr-dev
0 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,927 kB of archives.
After this operation, 12.4 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Err:1 http://gb.archive.ubuntu.com/ubuntu hirsute/main amd64 libgmpxx4ldbl amd64 2:6.2.1+dfsg-1ubuntu2
  404  Not Found [IP: 185.125.190.36 80]
Err:2 http://gb.archive.ubuntu.com/ubuntu hirsute/main amd64 libgmp-dev amd64 2:6.2.1+dfsg-1ubuntu2
  404  Not Found [IP: 185.125.190.36 80]
Err:3 http://gb.archive.ubuntu.com/ubuntu hirsute/main amd64 libmpfr-dev amd64 4.1.0-3build1
  404  Not Found [IP: 185.125.190.36 80]
Err:4 http://gb.archive.ubuntu.com/ubuntu hirsute/main amd64 libmpc-dev amd64 1.2.0-1build1
  404  Not Found [IP: 185.125.190.36 80]
Err:5 http://gb.archive.ubuntu.com/ubuntu hirsute/universe amd64 gcc-10-plugin-dev amd64 10.3.0-1ubuntu1
  404  Not Found [IP: 185.125.190.36 80]
E: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/pool/main/g/gmp/libgmpxx4ldbl_6.2.1%2bdfsg-1ubuntu2_amd64.deb  404  Not Found [IP: 185.125.190.36 80]
E: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/pool/main/g/gmp/libgmp-dev_6.2.1%2bdfsg-1ubuntu2_amd64.deb  404  Not Found [IP: 185.125.190.36 80]
E: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/pool/main/m/mpfr4/libmpfr-dev_4.1.0-3build1_amd64.deb  404  Not Found [IP: 185.125.190.36 80]
E: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/pool/main/m/mpclib3/libmpc-dev_1.2.0-1build1_amd64.deb  404  Not Found [IP: 185.125.190.36 80]
E: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/pool/universe/g/gcc-10/gcc-10-plugin-dev_10.3.0-1ubuntu1_amd64.deb  404  Not Found [IP: 185.125.190.36 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Si je vais à http://gb.archive.ubuntu.com/ubuntu/pool/main/g/gmp , par exemple pour la dépendance libgmp-dev, je peux voir qu'il existe un fichier nommé libgmp10_6.2.1+dfsg-3ubuntu1_amd64.deb , mais apt semble rechercher libgmp10_6.2.1+dfsg-1ubuntu2_amd64.deb .

Comment puis-je résoudre ce problème ?


Vous essayez de mettre à niveau et d'installer des packages sur une version qui n'est plus prise en charge annonce . Votre meilleur pari est probablement de mettre à niveau vers une version plus récente, de préférence une version avec support à long terme si vous ne voulez pas mettre à niveau (ce qui peut prendre un certain temps) tous les 6 mois.