Elastic Kubernetes Service

Impossibile aggiornare EKS

Hi,

Ho un cluster EKS con la versione 1.16 e ho provato ad aggiornare alla 1.17 ma non è riuscito con il seguente errore a causa del gruppo di sicurezza predefinito mancante (eliminato)

13-11-2021 09:19:19 aggiornerà il piano di controllo del cluster "xxx" dalla versione corrente "1.16" a "1.17" Errore: InvalidRequestException: il gruppo di sicurezza 'sg-0fdxxx' non esiste (servizio: AmazonEC2; stato Codice: 400; Codice di errore: InvalidGroup.NotFound; ID richiesta: xxx-xxx-xxx-xxx-xxx; Proxy: null)

Sembra che non ci sia altro modo per aggiornarlo,quindi aspetto che AWS mi costringa ad aggiornarlo quando arriva la data di fine supporto.Tuttavia,non è successo nulla.Vorrei quindi chiedere se è possibile ripristinare il vecchio gruppo di sicurezza o rimuovere quello predefinito nel cluster attuale per consentire l'aggiornamento o meno.

Thanks

Se questo era il gruppo di sicurezza del piano di controllo, non credo che tu possa modificarlo e non sarai in grado di ricreare l'ID del gruppo di sicurezza. L'opzione migliore a questo punto è ricostruire il cluster. Si prega di consultare anche: https://github.com/aws/containers-roadmap/issues/738




Sì,ho visto questo problema molto tempo fa.Tuttavia,il mio cluster qui è quello di produzione e ci vorrà più impegno per ricostruire e migrare tutte le cose lì.Mi chiedo anche perché l'aggiornamento forzato non avvenga.Almeno posso provare a programmare un periodo di inattività per questo.