Elastic Kubernetes Service

Não é possível actualizar o EKS

Hi,

Tenho um cluster EKS com versão 1.16 e tento actualizar para 1.17 mas falhei com o seguinte erro devido à falta do grupo de segurança padrão (eliminado)

13/11/2021 09:19:19 atualizará o plano de controle do cluster "xxx" da versão atual "1.16" para "1.17" Erro: InvalidRequestException: O grupo de segurança 'sg-0fdxxx' não existe (Serviço: AmazonEC2; Status Código: 400; Código de erro: InvalidGroup.NotFound; ID da solicitação: xxx-xxx-xxx-xxx-xxx; Proxy: null)

Parece não haver outra forma de o actualizar,pelo que espero pela actualização da força da AWS quando chegar ao fim da data de apoio.No entanto,nada aconteceu.Por isso,gostaria de perguntar se,de qualquer forma,existe a possibilidade de restaurar o antigo grupo de segurança ou remover o grupo padrão no actual cluster para permitir ou não a actualização

Thanks

Se este fosse o grupo de segurança do plano de controle, não acredito que você possa modificar isso e não poderá recriar o ID do grupo de segurança. Sua melhor opção neste momento é reconstruir o cluster. Consulte também: https://github.com/aws/containers-roadmap/issues/738




Sim,vi essa questão há muito tempo atrás.No entanto,o meu agrupamento aqui é de produção e será necessário mais esforço para reconstruir e migrar todas as coisas para lá.Também me pergunto porque é que a actualização da força não acontece.Pelo menos,posso tentar marcar o tempo de paragem para isto